Header_image
Jeremy Walker

Software Developer & Social Entrepreneur

RubyGems 1.8.2 broke my Rake

This is probably some weird thing on my system, but after updating RubyGems, I started getting errors like this when running Rake tasks

WARNING: Possible conflict with Rake extension: String#ext already exists
WARNING: Possible conflict with Rake extension: String#pathmap already exists

I tried removing various gems, playing with versions and generally wasting a bit of time. In the end, a simple downgrade fixed me again:

gem update --system 1.7.2
bundle install

Hope this helps someone!

Share This Post

Comments

No-one has posted a comment yet. Be the first!

Post a Comment

I'd love to hear your thoughts :)